Naoki Aoyama
naa0yama's Blog

naa0yama's Blog

FS.com のスイッチを買った

FS.com スイッチ s3910-24tf, s3410-10tf-p を購入しました

FS.com のスイッチを買った
Naoki Aoyama's photo
Naoki Aoyama

Published on Jul 18, 2021

4 min read

購入した物

購入経緯

弊宅では、去年の年末に MINISFORUM DeskMini DMAF5 を購入した事で仮想マシンクラスターが常時稼働する状況になり、ESXi では物足りなかった仮想マシンの自動バックアップ、ライブマイグレーションなどの機能が使えるようになりQoL(Quolity of life)が上昇。 この、 DMAF5 は NIC が2本ある。。。そうなると Link Aggregation(Port Cannel,LAG) したくなるがエンジニアでしょう。 その頃、弊宅でCore SW として稼働していたのは、 Switch-M24eG(PN28240)である。 こいつは、LAGに対応しているがLACP Static しか対応していないためリンク状態でリンクを変更したりできない。 そこでいくつかの選定状況を決め各社のスイッチのスペックシート等で比較検討した

選定候補

  • NETGEAR
    • NETGEAR Insight の機能でアプリにより設定変更が出来るらしいがその機能がサブスクリプション性に変更となり、1台あたりで料金がかかるらしいので予選落ち
  • Panasonic
    • 高価であり、既存のSWとあまり変わらなったので予選落ち
  • fs.com
  • Cisco
    • Meraki
      • サブスクリプション更新費、サポート状況がわからないので予選落ち

Ref

選定条件

[ほしい] PoE がほしい

WS-3560CG-8PC-S で Wi-Fi 電源供給してるが現状それしか仕事をしてないためリプレースを検討していた。ため、 PoE も 8Port ぐらいほしい。

[必須] Console があること

シリアルコンソールで設定できないSwitchはいらない(個人の感想です)

[必須] VLAN, Trunk, LACP, SNMP, NTP, SSH

この辺の機能はほしい。 一般家庭でもVLANを切ったりしてる所は少なからずあると思うので弊宅が特殊なわけではない ( 甘ゆくば、BGP, Cumulus ぐらいほしいが今回はL2なので除外,,,,

[必須] ファンレスであること

弊宅では6畳の部屋で生活しているため、常時稼働機器としては静音機器にこだわっている。 ほとんどの機材で 25dB以下になるように定常稼働するように設定している。

なりより睡眠を妨害されると心を闇むのでまずい!!

そこで 10Gbit が捨てられなかったためツイッターで見つけた @FSCOMJapan に凸った twitter.com/FSCOMJapan/status/1400997870694..

ノイズレベルは、dBの数値で測れるが、測定器がそのへんに転がってる事は稀で、基本的に人の感覚での回答なってしまうが、上記のツイッター投稿だけで Apple Watch のアプリを利用して、動画でご返信いただきました。 正直、金曜の夜に投げて土曜日に返信が帰ってきたのも驚きでしたが、休日出勤して一般家庭でもどのぐらいのノイズかわかるか比較できる方法でやっていただいたのが非常に感激した。 (その説大変、はお世話になりました。

ということで、安眠が守られ弊宅では 10Gbit 化は延期されました。

High, Low

総じて満足しています。 ちょっと高くなってもいいから L3 機能が入ってくると嬉しい (一般家庭でも BGP したくなるので static route から卒業したい,,,

High

  • Cisco の CLI 設定がわかれば苦しまずに設定出来る
  • LACP ちゃんと設定出来る
  • port-group 設定するとちゃんと interface の設定が変更され再度設定する時、警告文付きでできない旨出してくれる
  • サポート資料に Zabbix の Template がある
    弊宅ではこれをカスタムして使っている
  • Private MIB も登録なしにダウンロード出来る
    一般のベンダーのように保守契約が無いと各種資料がダウンロードで出来ないなんてことがない。
  • SFPポートがあるので光遊びが出来る
    揃えるとそれなりのお金が旅立つので今回は買わなかった
  • SNMP でトランシーバー温度,光レベルが確認出来る
    Private MIB を読むとちゃんと書いてあるので値が監視できそうである。

Low

  • WebUI の ID admin 以外から変更できない
    マニュアルを見るとわかるが、ユーザーを作成して権限を割り振っても admin と同等の権限を振る事ができないため admin を無効化もできない
  • Telnet が標準で開いてる
    デフォルト設定で開いてるようだ、よろしくないので無効化した
  • SSH が チャレンジレスポンス認証する必要あり
    鍵認証に設定する事が出来るが鍵でログインを確認できなかった
  • NTP サーバーが固定であり WebGUI から変更不可
    デフォルトが中国の怪しいやつであり、CLIで showコマンドで見るまで気づかなかった。変更は CLI でする必要あり

configuration

img-en.fs.com/file/user_manual/s3910-series..

WebUI の admin を変更

しようとおもったがドキュメントに 削除できない旨がしっかり書いてる,,,デフォルトユーザーは消せない模様

By default, the system creates the admin account. The account cannot be deleted and only the password of the
account can be changed. The administrator account is the admin account, which corresponds to the level 0 permission. The administrator account owns all permissions on the Web client and can edit other management accounts and
authorize the accountsto access pages. The new accounts that are added correspond to the level 1 permission.

デフォルトでは、システムはadminアカウントを作成します。このアカウントは削除することができず、アカウントのパスワードのみを変更することができます。管理者アカウントは、レベル0の権限に相当するadminアカウントです。管理者アカウントは、Webクライアント上のすべての権限を所有し、他の管理アカウントを編集したり、アカウントにページへのアクセスを許可することができます。新たに追加されたアカウントは、レベル1の権限に対応します。

https で 証明書を入れ替える

copy コマンドでファイル転送しておく

copy tftp://192.0.2.1/usercert.pfx flash:usercert.pfx
web-server https certificate { pem cert-filename private-key key-filename } | { pfx cert-filename } [ password
password-text ]

証明書の確認

show web-server https certificate information

保存したファイルの確認

dir flash:/

hostname

hostname s3910-24tf-01

sntp

sntp interval 7200
sntp server ntp.nict.jp
sntp enable

dns

ip name-server 10.1.1.11

ssh

ip ssh version 2
ip ssh source-interface VLAN 221
enable service ssh-server

telnet

使わないので無効に

no enable service telnet-server

snmp

snmp-server location Home Rack
snmp-server host 10.1.11.21 traps version 2c naa0yama
snmp-server host 10.1.11.22 traps version 2c naa0yama
snmp-server enable traps
snmp-server community naa0yama ro mgmt-net

timezone

clock timezone UTC +9 0

syslog

service standard-syslog
service sysname
service timestamps debug datetime year
service timestamps log datetime msec year
logging buffered 1048576
logging source interface VLAN 221
logging facility local7
logging server 10.1.11.21
logging server 10.1.11.22
logging trap informational

no service log-format rfc5424
no service sequence-numbers
  • cisco と同じフォーマットにした
Jun 18 22:33:45 10.2.21.114 s3910-24tf-01: %SYS-5-CONFIG_I: Configured from console by console
{
  "event": {
    "created": "2021-06-18T22:33:45.142+09:00"
  },
  "host": {
    "hostname": "10.2.21.114"
  },
  "process": {
    "name": "s3910-24tf-01",
    "pid": 0
  },
  "log": {
    "original": " Jun 18 2021 22:33:45.142 s3910-24tf-01: %SYS-5-CONFIG_I: Configured from console by console"
  },
  "syslog": {
    "facility_label": "local7",
    "severity_label": "notice"
  },
  "rsyslog": {
    "log": {
      "timegenerated": "2021-06-18T22:33:46.010423+09:00",
      "fromhost": {
        "address": "10.2.21.114",
        "ip": "10.2.21.114"
      },
      "inputname": "imudp"
    }
  }
}

AggregatePort

!
interface GigabitEthernet 0/23
 description s3410-10tf-p-01 Gi0/09
 port-group 23 mode active
!
interface GigabitEthernet 0/24
 description s3410-10tf-p-01 Gi0/10
 port-group 23 mode active
!
!
interface AggregatePort 23
 switchport mode trunk
!

show run

s3910-24tf-01#show run

Building configuration...
Current configuration: 4114 bytes

version S3910_FSOS 11.4(1)B74S2
hostname s3910-24tf-01
!
no spanning-tree
!
ip access-list extended mgmt-net
 10 permit ip 10.1.11.0 0.0.0.255 any
 20 permit ip 10.2.21.0 0.0.0.255 any
!
sntp interval 7200
sntp server ntp.nict.jp
sntp enable
!
!
no cwmp
!
install 0 S3910-24TF
!
ip name-server 10.1.1.11
!
nfpp
!
service password-encryption
!
redundancy
!
ip ssh version 2
ip ssh source-interface VLAN 221
service standard-syslog
service sysname
service timestamps debug datetime year
service timestamps log datetime msec year
logging buffered 1048576
logging source interface VLAN 221
logging server 10.1.11.21
logging server 10.1.11.22
clock timezone UTC +9 0
!
enable password hoge
enable service ssh-server
no enable service telnet-server
!
vlan range 221
!
interface GigabitEthernet 0/23
 description s3410-10tf-p-01 Gi0/09
 port-group 23 mode active
!
interface GigabitEthernet 0/24
 description s3410-10tf-p-01 Gi0/10
 port-group 23 mode active
!
interface AggregatePort 23
 switchport mode trunk
!
interface VLAN 221
 ip address 10.2.21.114 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.2.21.1
!
snmp-server location Home Rack
snmp-server host 10.1.11.21 traps version 2c naa0yama
snmp-server host 10.1.11.22 traps version 2c naa0yama
snmp-server enable traps
snmp-server community naa0yama ro mgmt-net
!
end
 
Share this